summaryrefslogtreecommitdiffstats
Side-by-side diff
-rw-r--r--configure.ac62
-rw-r--r--doc/build-cobalt.txt24
-rw-r--r--src/Makefile.am6
-rw-r--r--src/assign/assign_blast_scores.c27
-rw-r--r--src/assign/assign_blast_scores.h12
-rw-r--r--src/updator.c20
6 files changed, 127 insertions, 24 deletions
diff --git a/configure.ac b/configure.ac
index 59c5f36..f1ecdf9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,20 +7,16 @@ AC_CONFIG_FILES([
src/Makefile
])
-################
-# MODULE: HDF5 #
-################
+# Headers Checks
-AC_SEARCH_LIBS([H5Fcreate],[hdf5],[],
-[AC_MSG_ERROR(The HDF5 libraries are needed to build the system.)],
-[-lirc -lmpi -lz -lsz])
+AC_CHECK_HEADERS([hdf5.h],[],
+[AC_MSG_ERROR("The HDF5 headers are needed to build the system.")])
-AC_SEARCH_LIBS([H5TBmake_table],[hdf5_hl],[],
-[AC_MSG_ERROR(The HDF5 libraries are needed to build the system.)],
-[-lirc -lhdf5 -lmpi -lz -lsz])
+AC_CHECK_HEADERS([petscconf.h],[],
+[AC_MSG_ERROR("The PETSc headers are needed to build the system.")])
-AC_CHECK_HEADERS([hdf5.h],[],
-[AC_MSG_ERROR(The HDF5 headers are needed to build the system.)])
+AC_CHECK_HEADERS([petscmat.h],[],
+[AC_MSG_ERROR("The PETSc headers are needed to build the system.")])
########################
# MODULE: NCBI Toolkit #
@@ -28,18 +24,52 @@ AC_CHECK_HEADERS([hdf5.h],[],
# Check for the NCBI ToolBox libraries.
AC_SEARCH_LIBS([log10],[m],[],
-[AC_MSG_ERROR(The C Math Library is needed to build the system.)])
+[AC_MSG_ERROR("The C Math Library is needed to build the system.")])
AC_SEARCH_LIBS([NlmThreadsAvailable],[ncbi],[],
-[AC_MSG_ERROR(The NCBI ToolBox is needed to build the system. Information on this API can be found on-line at http://www.ncbi.nlm.nih.gov/IEB/ToolBox/index.cgi. Debian users can add the package libncbi6-dev to fulfill this dependency.)])
+[AC_MSG_ERROR("The NCBI ToolBox is needed to build the system. Information on this API can be found on-line at http://www.ncbi.nlm.nih.gov/IEB/ToolBox/index.cgi. Debian users can add the package libncbi6-dev to fulfill this dependency.")])
AC_SEARCH_LIBS([SeqAlignNew],[ncbiobj],[],
-[AC_MSG_ERROR(The NCBI ToolBox is needed to build the system. Information on this API can be found on-line at http://www.ncbi.nlm.nih.gov/IEB/ToolBox/index.cgi. Debian users can add the package libncbi6-dev to fulfill this dependency.)])
+[AC_MSG_ERROR("The NCBI ToolBox is needed to build the system. Information on this API can be found on-line at http://www.ncbi.nlm.nih.gov/IEB/ToolBox/index.cgi. Debian users can add the package libncbi6-dev to fulfill this dependency.")])
AC_SEARCH_LIBS([Blast_RedoOneMatch],[blastcompadj],[],
-[AC_MSG_ERROR(The NCBI ToolBox is needed to build the system. Information on this API can be found on-line at http://www.ncbi.nlm.nih.gov/IEB/ToolBox/index.cgi. Debian users can add the package libncbi6-dev to fulfill this dependency.)])
+[AC_MSG_ERROR("The NCBI ToolBox is needed to build the system. Information on this API can be found on-line at http://www.ncbi.nlm.nih.gov/IEB/ToolBox/index.cgi. Debian users can add the package libncbi6-dev to fulfill this dependency.")])
AC_SEARCH_LIBS([BioseqBlastEngine],[ncbitool],[],
-[AC_MSG_ERROR(The NCBI ToolBox is needed to build the system. Information on this API can be found on-line at http://www.ncbi.nlm.nih.gov/IEB/ToolBox/index.cgi. Debian users can add the package libncbi6-dev to fulfill this dependency.)])
+[AC_MSG_ERROR("The NCBI ToolBox is needed to build the system. Information on this API can be found on-line at http://www.ncbi.nlm.nih.gov/IEB/ToolBox/index.cgi. Debian users can add the package libncbi6-dev to fulfill this dependency.")])
+
+################
+# MODULE: HDF5 #
+################
+
+AC_SEARCH_LIBS([__intel_rtc_uninit_use],[irc])
+AC_SEARCH_LIBS([MPI_File_open],[mpi])
+AC_SEARCH_LIBS([compress2],[z])
+AC_SEARCH_LIBS([SZ_BufftoBuffCompress],[sz])
+
+AC_SEARCH_LIBS([H5Fcreate],[hdf5],[],
+[AC_MSG_ERROR("The HDF5 libraries are needed to build the system.")])
+
+AC_SEARCH_LIBS([H5TBmake_table],[hdf5_hl],[],
+[AC_MSG_ERROR("The HDF5 libraries are needed to build the system.")])
+
+#################
+# MODULE: PETSc #
+#################
+
+# The AC_SEARCH_LIBS other-libraries list is not particularly useful.
+# Autoconf determines if the other-libraries are necessary however in
+# the cases where they are indeed necessary they are not actually
+# added to the library list.
+
+# These are the dependencies. Random functions are selected from
+# these libraries from the list of otherwise undefined references at
+# link time.
+AC_SEARCH_LIBS([PetscInitialize],[petsc])
+AC_SEARCH_LIBS([VecNorm],[petscvec])
+
+# MatCreateSeqAIJ is acutally used in the code for this project.
+AC_SEARCH_LIBS([MatCreateSeqAIJ],[petscmat],[],
+[AC_MSG_ERROR("The Portable Extensible Tookit for Scientific Computation PETSc is needed to build the system.")])
AC_OUTPUT

Valid XHTML 1.0 Strict

Copyright © 2009 Don Pellegrino All Rights Reserved.