summaryrefslogtreecommitdiffstats
Side-by-side diff
-rw-r--r--configure.ac20
-rw-r--r--src/Makefile.am6
-rw-r--r--src/aggregator.c14
-rw-r--r--src/assign_protein_type.c72
-rw-r--r--src/assign_protein_type.h6
-rw-r--r--src/check_error.c14
-rw-r--r--src/check_error.h11
-rw-r--r--src/check_h5_error.c12
-rw-r--r--src/check_h5_error.h12
-rw-r--r--src/check_ncbi_error.c13
-rw-r--r--src/check_ncbi_error.h13
-rw-r--r--src/load_influenza_aa_dat.c31
12 files changed, 211 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 3104df8..f45958c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,4 +24,24 @@ AC_CHECK_HEADERS([mpi.h],[],
AC_CHECK_HEADERS([hdf5.h],[],
[AC_MSG_ERROR(The HDF5 headers are needed to build the system.)])
+########################
+# MODULE: NCBI Toolkit #
+########################
+
+# Check for the NCBI ToolBox libraries.
+AC_SEARCH_LIBS([log10],[m],[],
+[AC_MSG_ERROR(The C Math Library is needed to build the system.)])
+
+AC_SEARCH_LIBS([NlmThreadsAvailable],[ncbi],[],
+[AC_MSG_ERROR(The NCBI ToolBox is needed to build the system. Information on this API can be found on-line at http://www.ncbi.nlm.nih.gov/IEB/ToolBox/index.cgi. Debian users can add the package libncbi6-dev to fulfill this dependency.)])
+
+AC_SEARCH_LIBS([SeqAlignNew],[ncbiobj],[],
+[AC_MSG_ERROR(The NCBI ToolBox is needed to build the system. Information on this API can be found on-line at http://www.ncbi.nlm.nih.gov/IEB/ToolBox/index.cgi. Debian users can add the package libncbi6-dev to fulfill this dependency.)])
+
+AC_SEARCH_LIBS([Blast_RedoOneMatch],[blastcompadj],[],
+[AC_MSG_ERROR(The NCBI ToolBox is needed to build the system. Information on this API can be found on-line at http://www.ncbi.nlm.nih.gov/IEB/ToolBox/index.cgi. Debian users can add the package libncbi6-dev to fulfill this dependency.)])
+
+AC_SEARCH_LIBS([BioseqBlastEngine],[ncbitool],[],
+[AC_MSG_ERROR(The NCBI ToolBox is needed to build the system. Information on this API can be found on-line at http://www.ncbi.nlm.nih.gov/IEB/ToolBox/index.cgi. Debian users can add the package libncbi6-dev to fulfill this dependency.)])
+
AC_OUTPUT

Valid XHTML 1.0 Strict

Copyright © 2009 Don Pellegrino All Rights Reserved.