-rw-r--r-- | .gitignore | 3 | ||||
-rwxr-xr-x | autogen.sh | 2 | ||||
-rw-r--r-- | configure.ac | 8 | ||||
-rw-r--r-- | doc/build-cobalt.txt | 42 | ||||
-rw-r--r-- | doc/env-cobalt.sh | 56 |
5 files changed, 65 insertions, 46 deletions
diff --git a/configure.ac b/configure.ac index f1ecdf9..aa1d3df 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -57,6 +57,11 @@ AC_SEARCH_LIBS([H5TBmake_table],[hdf5_hl],[], | |||
57 | # MODULE: PETSc # | 57 | # MODULE: PETSc # |
58 | ################# | 58 | ################# |
59 | 59 | ||
60 | AC_SEARCH_LIBS([pthread_atfork],[pthread]) | ||
61 | |||
62 | AC_SEARCH_LIBS([PetscInitialize],[petsc],[], | ||
63 | [AC_MSG_ERROR("The Portable Extensible Toolkit for Scientific Computation (PETSc) is needed to build the system.")]) | ||
64 | |||
60 | # The AC_SEARCH_LIBS other-libraries list is not particularly useful. | 65 | # The AC_SEARCH_LIBS other-libraries list is not particularly useful. |
61 | # Autoconf determines if the other-libraries are necessary however in | 66 | # Autoconf determines if the other-libraries are necessary however in |
62 | # the cases where they are indeed necessary they are not actually | 67 | # the cases where they are indeed necessary they are not actually |
@@ -65,11 +70,10 @@ AC_SEARCH_LIBS([H5TBmake_table],[hdf5_hl],[], | |||
65 | # These are the dependencies. Random functions are selected from | 70 | # These are the dependencies. Random functions are selected from |
66 | # these libraries from the list of otherwise undefined references at | 71 | # these libraries from the list of otherwise undefined references at |
67 | # link time. | 72 | # link time. |
68 | AC_SEARCH_LIBS([PetscInitialize],[petsc]) | ||
69 | AC_SEARCH_LIBS([VecNorm],[petscvec]) | 73 | AC_SEARCH_LIBS([VecNorm],[petscvec]) |
70 | 74 | ||
71 | # MatCreateSeqAIJ is acutally used in the code for this project. | 75 | # MatCreateSeqAIJ is acutally used in the code for this project. |
72 | AC_SEARCH_LIBS([MatCreateSeqAIJ],[petscmat],[], | 76 | AC_SEARCH_LIBS([MatCreateSeqAIJ],[petscmat],[], |
73 | [AC_MSG_ERROR("The Portable Extensible Tookit for Scientific Computation PETSc is needed to build the system.")]) | 77 | [AC_MSG_ERROR("The Portable Extensible Toolkit for Scientific Computation (PETSc) is needed to build the system.")]) |
74 | 78 | ||
75 | AC_OUTPUT | 79 | AC_OUTPUT |