summaryrefslogtreecommitdiffstats
Side-by-side diff
-rw-r--r--.gitignore3
-rwxr-xr-xautogen.sh2
-rw-r--r--configure.ac8
-rw-r--r--doc/build-cobalt.txt42
-rw-r--r--doc/env-cobalt.sh56
5 files changed, 65 insertions, 46 deletions
diff --git a/configure.ac b/configure.ac
index f1ecdf9..aa1d3df 100644
--- a/configure.ac
+++ b/configure.ac
@@ -57,6 +57,11 @@ AC_SEARCH_LIBS([H5TBmake_table],[hdf5_hl],[],
# MODULE: PETSc #
#################
+AC_SEARCH_LIBS([pthread_atfork],[pthread])
+
+AC_SEARCH_LIBS([PetscInitialize],[petsc],[],
+[AC_MSG_ERROR("The Portable Extensible Toolkit for Scientific Computation (PETSc) is needed to build the system.")])
+
# The AC_SEARCH_LIBS other-libraries list is not particularly useful.
# Autoconf determines if the other-libraries are necessary however in
# the cases where they are indeed necessary they are not actually
@@ -65,11 +70,10 @@ AC_SEARCH_LIBS([H5TBmake_table],[hdf5_hl],[],
# These are the dependencies. Random functions are selected from
# these libraries from the list of otherwise undefined references at
# link time.
-AC_SEARCH_LIBS([PetscInitialize],[petsc])
AC_SEARCH_LIBS([VecNorm],[petscvec])
# MatCreateSeqAIJ is acutally used in the code for this project.
AC_SEARCH_LIBS([MatCreateSeqAIJ],[petscmat],[],
-[AC_MSG_ERROR("The Portable Extensible Tookit for Scientific Computation PETSc is needed to build the system.")])
+[AC_MSG_ERROR("The Portable Extensible Toolkit for Scientific Computation (PETSc) is needed to build the system.")])
AC_OUTPUT

Valid XHTML 1.0 Strict

Copyright © 2009 Don Pellegrino All Rights Reserved.