summaryrefslogtreecommitdiffstats
Unidiff
-rw-r--r--configure.ac62
-rw-r--r--doc/build-cobalt.txt24
-rw-r--r--src/Makefile.am6
-rw-r--r--src/assign/assign_blast_scores.c27
-rw-r--r--src/assign/assign_blast_scores.h12
-rw-r--r--src/updator.c20
6 files changed, 127 insertions, 24 deletions
diff --git a/configure.ac b/configure.ac
index 59c5f36..f1ecdf9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,20 +7,16 @@ AC_CONFIG_FILES([
7 src/Makefile7 src/Makefile
8])8])
99
10################10# Headers Checks
11# MODULE: HDF5 #
12################
1311
14AC_SEARCH_LIBS([H5Fcreate],[hdf5],[],12AC_CHECK_HEADERS([hdf5.h],[],
15[AC_MSG_ERROR(The HDF5 libraries are needed to build the system.)],13[AC_MSG_ERROR("The HDF5 headers are needed to build the system.")])
16[-lirc -lmpi -lz -lsz])
1714
18AC_SEARCH_LIBS([H5TBmake_table],[hdf5_hl],[],15AC_CHECK_HEADERS([petscconf.h],[],
19[AC_MSG_ERROR(The HDF5 libraries are needed to build the system.)],16[AC_MSG_ERROR("The PETSc headers are needed to build the system.")])
20[-lirc -lhdf5 -lmpi -lz -lsz])
2117
22AC_CHECK_HEADERS([hdf5.h],[],18AC_CHECK_HEADERS([petscmat.h],[],
23[AC_MSG_ERROR(The HDF5 headers are needed to build the system.)])19[AC_MSG_ERROR("The PETSc headers are needed to build the system.")])
2420
25########################21########################
26# MODULE: NCBI Toolkit #22# MODULE: NCBI Toolkit #
@@ -28,18 +24,52 @@ AC_CHECK_HEADERS([hdf5.h],[],
2824
29# Check for the NCBI ToolBox libraries.25# Check for the NCBI ToolBox libraries.
30AC_SEARCH_LIBS([log10],[m],[],26AC_SEARCH_LIBS([log10],[m],[],
31[AC_MSG_ERROR(The C Math Library is needed to build the system.)])27[AC_MSG_ERROR("The C Math Library is needed to build the system.")])
3228
33AC_SEARCH_LIBS([NlmThreadsAvailable],[ncbi],[],29AC_SEARCH_LIBS([NlmThreadsAvailable],[ncbi],[],
34[AC_MSG_ERROR(The NCBI ToolBox is needed to build the system. Information on this API can be found on-line at http://www.ncbi.nlm.nih.gov/IEB/ToolBox/index.cgi. Debian users can add the package libncbi6-dev to fulfill this dependency.)])30[AC_MSG_ERROR("The NCBI ToolBox is needed to build the system. Information on this API can be found on-line at http://www.ncbi.nlm.nih.gov/IEB/ToolBox/index.cgi. Debian users can add the package libncbi6-dev to fulfill this dependency.")])
3531
36AC_SEARCH_LIBS([SeqAlignNew],[ncbiobj],[],32AC_SEARCH_LIBS([SeqAlignNew],[ncbiobj],[],
37[AC_MSG_ERROR(The NCBI ToolBox is needed to build the system. Information on this API can be found on-line at http://www.ncbi.nlm.nih.gov/IEB/ToolBox/index.cgi. Debian users can add the package libncbi6-dev to fulfill this dependency.)])33[AC_MSG_ERROR("The NCBI ToolBox is needed to build the system. Information on this API can be found on-line at http://www.ncbi.nlm.nih.gov/IEB/ToolBox/index.cgi. Debian users can add the package libncbi6-dev to fulfill this dependency.")])
3834
39AC_SEARCH_LIBS([Blast_RedoOneMatch],[blastcompadj],[],35AC_SEARCH_LIBS([Blast_RedoOneMatch],[blastcompadj],[],
40[AC_MSG_ERROR(The NCBI ToolBox is needed to build the system. Information on this API can be found on-line at http://www.ncbi.nlm.nih.gov/IEB/ToolBox/index.cgi. Debian users can add the package libncbi6-dev to fulfill this dependency.)])36[AC_MSG_ERROR("The NCBI ToolBox is needed to build the system. Information on this API can be found on-line at http://www.ncbi.nlm.nih.gov/IEB/ToolBox/index.cgi. Debian users can add the package libncbi6-dev to fulfill this dependency.")])
4137
42AC_SEARCH_LIBS([BioseqBlastEngine],[ncbitool],[],38AC_SEARCH_LIBS([BioseqBlastEngine],[ncbitool],[],
43[AC_MSG_ERROR(The NCBI ToolBox is needed to build the system. Information on this API can be found on-line at http://www.ncbi.nlm.nih.gov/IEB/ToolBox/index.cgi. Debian users can add the package libncbi6-dev to fulfill this dependency.)])39[AC_MSG_ERROR("The NCBI ToolBox is needed to build the system. Information on this API can be found on-line at http://www.ncbi.nlm.nih.gov/IEB/ToolBox/index.cgi. Debian users can add the package libncbi6-dev to fulfill this dependency.")])
40
41################
42# MODULE: HDF5 #
43################
44
45AC_SEARCH_LIBS([__intel_rtc_uninit_use],[irc])
46AC_SEARCH_LIBS([MPI_File_open],[mpi])
47AC_SEARCH_LIBS([compress2],[z])
48AC_SEARCH_LIBS([SZ_BufftoBuffCompress],[sz])
49
50AC_SEARCH_LIBS([H5Fcreate],[hdf5],[],
51[AC_MSG_ERROR("The HDF5 libraries are needed to build the system.")])
52
53AC_SEARCH_LIBS([H5TBmake_table],[hdf5_hl],[],
54[AC_MSG_ERROR("The HDF5 libraries are needed to build the system.")])
55
56#################
57# MODULE: PETSc #
58#################
59
60# The AC_SEARCH_LIBS other-libraries list is not particularly useful.
61# Autoconf determines if the other-libraries are necessary however in
62# the cases where they are indeed necessary they are not actually
63# added to the library list.
64
65# These are the dependencies. Random functions are selected from
66# these libraries from the list of otherwise undefined references at
67# link time.
68AC_SEARCH_LIBS([PetscInitialize],[petsc])
69AC_SEARCH_LIBS([VecNorm],[petscvec])
70
71# MatCreateSeqAIJ is acutally used in the code for this project.
72AC_SEARCH_LIBS([MatCreateSeqAIJ],[petscmat],[],
73[AC_MSG_ERROR("The Portable Extensible Tookit for Scientific Computation PETSc is needed to build the system.")])
4474
45AC_OUTPUT75AC_OUTPUT

Valid XHTML 1.0 Strict

Copyright © 2009 Don Pellegrino All Rights Reserved.