summaryrefslogtreecommitdiffstats
Unidiff
-rw-r--r--Makefile.am17
-rw-r--r--src/controller/actions/pan.c23
-rw-r--r--src/controller/actions/set_ortho.c5
-rw-r--r--src/controller/actions/zoom.c8
-rw-r--r--src/controller/callbacks/keyboard.c2
-rw-r--r--src/controller/callbacks/mouse.c30
-rw-r--r--src/controller/callbacks/mouse_motion.c2
-rw-r--r--src/controller/callbacks/mouse_wheel.c8
-rw-r--r--src/controller/callbacks/reshape.c26
-rw-r--r--src/model/geometry/map_geometry.c10
-rw-r--r--src/model/state/pan_info_init.h2
-rw-r--r--src/model/state/zoom_info_init.c2
12 files changed, 70 insertions, 65 deletions
diff --git a/Makefile.am b/Makefile.am
index 8638119..d54aa2f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,15 +1,26 @@
1ACLOCAL_AMFLAGS = -I ax1ACLOCAL_AMFLAGS = -I ax
2SUBDIRS = src2SUBDIRS = src
33
4# Ident formats the source code to conform with GNU style conventions.
4indent :5indent :
5 indent \6 indent \
6 src/*.c \7 src/*.c \
7 src/controller/*.c src/controller/*.sqc src/controller/*.h \8 src/controller/actions/*.c src/controller/actions/*.sqc src/controller/actions/*.h \
9 src/controller/callbacks/*.c src/controller/callbacks/*.h \
8 src/db/*.c src/db/*.sqc src/db/*.h \10 src/db/*.c src/db/*.sqc src/db/*.h \
9 src/model/*.c src/model/*.sqc src/model/*.h \11 src/model/data/*.c src/model/data/*.sqc src/model/data/*.h \
10 src/model/geometry/*.c src/mode/geometry/*.h \12 src/model/geometry/*.c src/model/geometry/*.h \
13 src/model/state/*.c src/model/state/*.h \
11 src/util/*.c src/util/*.h \14 src/util/*.c src/util/*.h \
12 src/util/amd_performance_monitor/*.c \15 src/util/amd_performance_monitor/*.c \
13 src/util/amd_performance_monitor/*.h \16 src/util/amd_performance_monitor/*.h \
14 src/view/*.c src/view/*.h17 src/view/*.c src/view/*.h
1518
19# Splint analyzes the code for security vulnerabilities and
20# programming mistakes. It would be great to add a target to run
21# splint here but as of Splint 3.1.2 it does not yet handle C99
22# variable declarations which are used heavily in this project. This
23# is discussed at
24# http://www.cs.virginia.edu/pipermail/splint-discuss/2009-March/001288.html.
25
26

Valid XHTML 1.0 Strict

Copyright © 2009 Don Pellegrino All Rights Reserved.