summaryrefslogtreecommitdiffstats
Side-by-side diff
-rw-r--r--Makefile.am17
-rw-r--r--src/controller/actions/pan.c23
-rw-r--r--src/controller/actions/set_ortho.c5
-rw-r--r--src/controller/actions/zoom.c8
-rw-r--r--src/controller/callbacks/keyboard.c2
-rw-r--r--src/controller/callbacks/mouse.c30
-rw-r--r--src/controller/callbacks/mouse_motion.c2
-rw-r--r--src/controller/callbacks/mouse_wheel.c8
-rw-r--r--src/controller/callbacks/reshape.c26
-rw-r--r--src/model/geometry/map_geometry.c10
-rw-r--r--src/model/state/pan_info_init.h2
-rw-r--r--src/model/state/zoom_info_init.c2
12 files changed, 70 insertions, 65 deletions
diff --git a/Makefile.am b/Makefile.am
index 8638119..d54aa2f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,15 +1,26 @@
ACLOCAL_AMFLAGS = -I ax
SUBDIRS = src
+# Ident formats the source code to conform with GNU style conventions.
indent :
indent \
src/*.c \
- src/controller/*.c src/controller/*.sqc src/controller/*.h \
+ src/controller/actions/*.c src/controller/actions/*.sqc src/controller/actions/*.h \
+ src/controller/callbacks/*.c src/controller/callbacks/*.h \
src/db/*.c src/db/*.sqc src/db/*.h \
- src/model/*.c src/model/*.sqc src/model/*.h \
- src/model/geometry/*.c src/mode/geometry/*.h \
+ src/model/data/*.c src/model/data/*.sqc src/model/data/*.h \
+ src/model/geometry/*.c src/model/geometry/*.h \
+ src/model/state/*.c src/model/state/*.h \
src/util/*.c src/util/*.h \
src/util/amd_performance_monitor/*.c \
src/util/amd_performance_monitor/*.h \
src/view/*.c src/view/*.h
+# Splint analyzes the code for security vulnerabilities and
+# programming mistakes. It would be great to add a target to run
+# splint here but as of Splint 3.1.2 it does not yet handle C99
+# variable declarations which are used heavily in this project. This
+# is discussed at
+# http://www.cs.virginia.edu/pipermail/splint-discuss/2009-March/001288.html.
+
+

Valid XHTML 1.0 Strict

Copyright © 2009 Don Pellegrino All Rights Reserved.