summaryrefslogtreecommitdiffstats
Unidiff
-rw-r--r--.gitignore1
-rw-r--r--AUTHORS1
-rw-r--r--ChangeLog0
-rw-r--r--NEWS0
-rwxr-xr-xautogen.sh4
-rw-r--r--configure.ac27
6 files changed, 33 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..3104df8
--- a/dev/null
+++ b/configure.ac
@@ -0,0 +1,27 @@
1AC_INIT([exp007], [0.1], [don@drexel.edu])
2AM_INIT_AUTOMAKE([-Wall, -Werror, -Wno-portability])
3AC_PROG_CC
4AM_CONFIG_HEADER([config.h])
5AC_CONFIG_FILES([
6 Makefile
7 src/Makefile
8])
9
10################
11# MODULE: HDF5 #
12################
13
14AC_SEARCH_LIBS([H5Fcreate],[hdf5],[],
15[AC_MSG_ERROR(The HDF5 libraries are needed to build the system.)])
16
17AC_SEARCH_LIBS([H5TBmake_table],[hdf5_hl],[],
18[AC_MSG_ERROR(The HDF5 libraries are needed to build the system.)],
19[-lhdf5])
20
21AC_CHECK_HEADERS([mpi.h],[],
22[AC_MSG_ERROR(The MPI headers are needed to build the system.)])
23
24AC_CHECK_HEADERS([hdf5.h],[],
25[AC_MSG_ERROR(The HDF5 headers are needed to build the system.)])
26
27AC_OUTPUT

Valid XHTML 1.0 Strict

Copyright © 2009 Don Pellegrino All Rights Reserved.