-rw-r--r-- | configure.ac | 62 | ||||
-rw-r--r-- | doc/build-cobalt.txt | 24 | ||||
-rw-r--r-- | src/Makefile.am | 6 | ||||
-rw-r--r-- | src/assign/assign_blast_scores.c | 27 | ||||
-rw-r--r-- | src/assign/assign_blast_scores.h | 12 | ||||
-rw-r--r-- | src/updator.c | 20 |
6 files changed, 127 insertions, 24 deletions
diff --git a/configure.ac b/configure.ac index 59c5f36..f1ecdf9 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -7,20 +7,16 @@ AC_CONFIG_FILES([ | |||
7 | src/Makefile | 7 | src/Makefile |
8 | ]) | 8 | ]) |
9 | 9 | ||
10 | ################ | 10 | # Headers Checks |
11 | # MODULE: HDF5 # | ||
12 | ################ | ||
13 | 11 | ||
14 | AC_SEARCH_LIBS([H5Fcreate],[hdf5],[], | 12 | AC_CHECK_HEADERS([hdf5.h],[], |
15 | [AC_MSG_ERROR(The HDF5 libraries are needed to build the system.)], | 13 | [AC_MSG_ERROR("The HDF5 headers are needed to build the system.")]) |
16 | [-lirc -lmpi -lz -lsz]) | ||
17 | 14 | ||
18 | AC_SEARCH_LIBS([H5TBmake_table],[hdf5_hl],[], | 15 | AC_CHECK_HEADERS([petscconf.h],[], |
19 | [AC_MSG_ERROR(The HDF5 libraries are needed to build the system.)], | 16 | [AC_MSG_ERROR("The PETSc headers are needed to build the system.")]) |
20 | [-lirc -lhdf5 -lmpi -lz -lsz]) | ||
21 | 17 | ||
22 | AC_CHECK_HEADERS([hdf5.h],[], | 18 | AC_CHECK_HEADERS([petscmat.h],[], |
23 | [AC_MSG_ERROR(The HDF5 headers are needed to build the system.)]) | 19 | [AC_MSG_ERROR("The PETSc headers are needed to build the system.")]) |
24 | 20 | ||
25 | ######################## | 21 | ######################## |
26 | # MODULE: NCBI Toolkit # | 22 | # MODULE: NCBI Toolkit # |
@@ -28,18 +24,52 @@ AC_CHECK_HEADERS([hdf5.h],[], | |||
28 | 24 | ||
29 | # Check for the NCBI ToolBox libraries. | 25 | # Check for the NCBI ToolBox libraries. |
30 | AC_SEARCH_LIBS([log10],[m],[], | 26 | AC_SEARCH_LIBS([log10],[m],[], |
31 | [AC_MSG_ERROR(The C Math Library is needed to build the system.)]) | 27 | [AC_MSG_ERROR("The C Math Library is needed to build the system.")]) |
32 | 28 | ||
33 | AC_SEARCH_LIBS([NlmThreadsAvailable],[ncbi],[], | 29 | AC_SEARCH_LIBS([NlmThreadsAvailable],[ncbi],[], |
34 | [AC_MSG_ERROR(The NCBI ToolBox is needed to build the system. Information on this API can be found on-line at http://www.ncbi.nlm.nih.gov/IEB/ToolBox/index.cgi. Debian users can add the package libncbi6-dev to fulfill this dependency.)]) | 30 | [AC_MSG_ERROR("The NCBI ToolBox is needed to build the system. Information on this API can be found on-line at http://www.ncbi.nlm.nih.gov/IEB/ToolBox/index.cgi. Debian users can add the package libncbi6-dev to fulfill this dependency.")]) |
35 | 31 | ||
36 | AC_SEARCH_LIBS([SeqAlignNew],[ncbiobj],[], | 32 | AC_SEARCH_LIBS([SeqAlignNew],[ncbiobj],[], |
37 | [AC_MSG_ERROR(The NCBI ToolBox is needed to build the system. Information on this API can be found on-line at http://www.ncbi.nlm.nih.gov/IEB/ToolBox/index.cgi. Debian users can add the package libncbi6-dev to fulfill this dependency.)]) | 33 | [AC_MSG_ERROR("The NCBI ToolBox is needed to build the system. Information on this API can be found on-line at http://www.ncbi.nlm.nih.gov/IEB/ToolBox/index.cgi. Debian users can add the package libncbi6-dev to fulfill this dependency.")]) |
38 | 34 | ||
39 | AC_SEARCH_LIBS([Blast_RedoOneMatch],[blastcompadj],[], | 35 | AC_SEARCH_LIBS([Blast_RedoOneMatch],[blastcompadj],[], |
40 | [AC_MSG_ERROR(The NCBI ToolBox is needed to build the system. Information on this API can be found on-line at http://www.ncbi.nlm.nih.gov/IEB/ToolBox/index.cgi. Debian users can add the package libncbi6-dev to fulfill this dependency.)]) | 36 | [AC_MSG_ERROR("The NCBI ToolBox is needed to build the system. Information on this API can be found on-line at http://www.ncbi.nlm.nih.gov/IEB/ToolBox/index.cgi. Debian users can add the package libncbi6-dev to fulfill this dependency.")]) |
41 | 37 | ||
42 | AC_SEARCH_LIBS([BioseqBlastEngine],[ncbitool],[], | 38 | AC_SEARCH_LIBS([BioseqBlastEngine],[ncbitool],[], |
43 | [AC_MSG_ERROR(The NCBI ToolBox is needed to build the system. Information on this API can be found on-line at http://www.ncbi.nlm.nih.gov/IEB/ToolBox/index.cgi. Debian users can add the package libncbi6-dev to fulfill this dependency.)]) | 39 | [AC_MSG_ERROR("The NCBI ToolBox is needed to build the system. Information on this API can be found on-line at http://www.ncbi.nlm.nih.gov/IEB/ToolBox/index.cgi. Debian users can add the package libncbi6-dev to fulfill this dependency.")]) |
40 | |||
41 | ################ | ||
42 | # MODULE: HDF5 # | ||
43 | ################ | ||
44 | |||
45 | AC_SEARCH_LIBS([__intel_rtc_uninit_use],[irc]) | ||
46 | AC_SEARCH_LIBS([MPI_File_open],[mpi]) | ||
47 | AC_SEARCH_LIBS([compress2],[z]) | ||
48 | AC_SEARCH_LIBS([SZ_BufftoBuffCompress],[sz]) | ||
49 | |||
50 | AC_SEARCH_LIBS([H5Fcreate],[hdf5],[], | ||
51 | [AC_MSG_ERROR("The HDF5 libraries are needed to build the system.")]) | ||
52 | |||
53 | AC_SEARCH_LIBS([H5TBmake_table],[hdf5_hl],[], | ||
54 | [AC_MSG_ERROR("The HDF5 libraries are needed to build the system.")]) | ||
55 | |||
56 | ################# | ||
57 | # MODULE: PETSc # | ||
58 | ################# | ||
59 | |||
60 | # The AC_SEARCH_LIBS other-libraries list is not particularly useful. | ||
61 | # Autoconf determines if the other-libraries are necessary however in | ||
62 | # the cases where they are indeed necessary they are not actually | ||
63 | # added to the library list. | ||
64 | |||
65 | # These are the dependencies. Random functions are selected from | ||
66 | # these libraries from the list of otherwise undefined references at | ||
67 | # link time. | ||
68 | AC_SEARCH_LIBS([PetscInitialize],[petsc]) | ||
69 | AC_SEARCH_LIBS([VecNorm],[petscvec]) | ||
70 | |||
71 | # MatCreateSeqAIJ is acutally used in the code for this project. | ||
72 | AC_SEARCH_LIBS([MatCreateSeqAIJ],[petscmat],[], | ||
73 | [AC_MSG_ERROR("The Portable Extensible Tookit for Scientific Computation PETSc is needed to build the system.")]) | ||
44 | 74 | ||
45 | AC_OUTPUT | 75 | AC_OUTPUT |