-rw-r--r-- | configure.ac | 20 | ||||
-rw-r--r-- | src/Makefile.am | 6 | ||||
-rw-r--r-- | src/aggregator.c | 14 | ||||
-rw-r--r-- | src/assign_protein_type.c | 72 | ||||
-rw-r--r-- | src/assign_protein_type.h | 6 | ||||
-rw-r--r-- | src/check_error.c | 14 | ||||
-rw-r--r-- | src/check_error.h | 11 | ||||
-rw-r--r-- | src/check_h5_error.c | 12 | ||||
-rw-r--r-- | src/check_h5_error.h | 12 | ||||
-rw-r--r-- | src/check_ncbi_error.c | 13 | ||||
-rw-r--r-- | src/check_ncbi_error.h | 13 | ||||
-rw-r--r-- | src/load_influenza_aa_dat.c | 31 |
12 files changed, 211 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac index 3104df8..f45958c 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -24,4 +24,24 @@ AC_CHECK_HEADERS([mpi.h],[], | |||
24 | AC_CHECK_HEADERS([hdf5.h],[], | 24 | AC_CHECK_HEADERS([hdf5.h],[], |
25 | [AC_MSG_ERROR(The HDF5 headers are needed to build the system.)]) | 25 | [AC_MSG_ERROR(The HDF5 headers are needed to build the system.)]) |
26 | 26 | ||
27 | ######################## | ||
28 | # MODULE: NCBI Toolkit # | ||
29 | ######################## | ||
30 | |||
31 | # Check for the NCBI ToolBox libraries. | ||
32 | AC_SEARCH_LIBS([log10],[m],[], | ||
33 | [AC_MSG_ERROR(The C Math Library is needed to build the system.)]) | ||
34 | |||
35 | AC_SEARCH_LIBS([NlmThreadsAvailable],[ncbi],[], | ||
36 | [AC_MSG_ERROR(The NCBI ToolBox is needed to build the system. Information on this API can be found on-line at http://www.ncbi.nlm.nih.gov/IEB/ToolBox/index.cgi. Debian users can add the package libncbi6-dev to fulfill this dependency.)]) | ||
37 | |||
38 | AC_SEARCH_LIBS([SeqAlignNew],[ncbiobj],[], | ||
39 | [AC_MSG_ERROR(The NCBI ToolBox is needed to build the system. Information on this API can be found on-line at http://www.ncbi.nlm.nih.gov/IEB/ToolBox/index.cgi. Debian users can add the package libncbi6-dev to fulfill this dependency.)]) | ||
40 | |||
41 | AC_SEARCH_LIBS([Blast_RedoOneMatch],[blastcompadj],[], | ||
42 | [AC_MSG_ERROR(The NCBI ToolBox is needed to build the system. Information on this API can be found on-line at http://www.ncbi.nlm.nih.gov/IEB/ToolBox/index.cgi. Debian users can add the package libncbi6-dev to fulfill this dependency.)]) | ||
43 | |||
44 | AC_SEARCH_LIBS([BioseqBlastEngine],[ncbitool],[], | ||
45 | [AC_MSG_ERROR(The NCBI ToolBox is needed to build the system. Information on this API can be found on-line at http://www.ncbi.nlm.nih.gov/IEB/ToolBox/index.cgi. Debian users can add the package libncbi6-dev to fulfill this dependency.)]) | ||
46 | |||
27 | AC_OUTPUT | 47 | AC_OUTPUT |