29 files changed, 1185 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am new file mode 100644 index 0000000..bd0d702 --- a/dev/null +++ b/src/Makefile.am | |||
@@ -0,0 +1,28 @@ | |||
1 | bin_PROGRAMS = exp004viz | ||
2 | |||
3 | exp004viz_SOURCES = \ | ||
4 | controller/exp004display.c \ | ||
5 | controller/exp004mouse.c \ | ||
6 | controller/exp004processhits.c \ | ||
7 | controller/exp004reshape.c \ | ||
8 | exp004viz.c \ | ||
9 | model/exp004base.c \ | ||
10 | util/check_error.c \ | ||
11 | view/exp004geometry.c \ | ||
12 | view/exp004view.c | ||
13 | |||
14 | exp004viz_LDADD = ${GLUT_LIBS} | ||
15 | |||
16 | noinst_HEADERS = \ | ||
17 | controller/exp004display.h \ | ||
18 | controller/exp004mouse.h \ | ||
19 | controller/exp004processhits.h \ | ||
20 | controller/exp004reshape.h \ | ||
21 | model/exp004base.h \ | ||
22 | model/exp004state.h \ | ||
23 | util/check_error.h \ | ||
24 | view/exp004geometry.h \ | ||
25 | view/exp004state0.h \ | ||
26 | view/exp004view.h | ||
27 | |||
28 | AM_CFLAGS = -Wall -std=gnu99 -pipe -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -I/usr/include/ncbi | ||