33 files changed, 530 insertions, 113 deletions
diff --git a/src/Makefile.am b/src/Makefile.am index 1ccb4f8..e2a3b72 100644 --- a/src/Makefile.am +++ b/src/Makefile.am | |||
@@ -1,6 +1,6 @@ | |||
1 | bin_PROGRAMS = exp004viz | 1 | bin_PROGRAMS = flumap |
2 | 2 | ||
3 | exp004viz_SOURCES = \ | 3 | flumap_SOURCES = \ |
4 | controller/actions/clear_selection.c \ | 4 | controller/actions/clear_selection.c \ |
5 | controller/actions/pan.c \ | 5 | controller/actions/pan.c \ |
6 | controller/actions/process_hits.c \ | 6 | controller/actions/process_hits.c \ |
@@ -14,8 +14,8 @@ exp004viz_SOURCES = \ | |||
14 | controller/callbacks/mouse_wheel.c \ | 14 | controller/callbacks/mouse_wheel.c \ |
15 | controller/callbacks/reshape.c \ | 15 | controller/callbacks/reshape.c \ |
16 | db/dbconnect.c \ | 16 | db/dbconnect.c \ |
17 | exp004viz.c \ | 17 | flumap.c \ |
18 | model/exp004base.c \ | 18 | model/base.c \ |
19 | model/geometry/density_legend_geometry.c \ | 19 | model/geometry/density_legend_geometry.c \ |
20 | model/geometry/map_geometry.c \ | 20 | model/geometry/map_geometry.c \ |
21 | model/geometry/protein_geometry.c \ | 21 | model/geometry/protein_geometry.c \ |
@@ -26,11 +26,11 @@ exp004viz_SOURCES = \ | |||
26 | util/check_error.c \ | 26 | util/check_error.c \ |
27 | util/pick_convert.c \ | 27 | util/pick_convert.c \ |
28 | util/sqlinfoprint.c \ | 28 | util/sqlinfoprint.c \ |
29 | view/exp004geometry.c \ | 29 | view/geometry.c \ |
30 | view/exp004init.c \ | 30 | view/init.c \ |
31 | view/exp004view.c | 31 | view/view.c |
32 | 32 | ||
33 | exp004viz_LDADD = ${GLUT_LIBS} | 33 | flumap_LDADD = ${GLUT_LIBS} |
34 | 34 | ||
35 | noinst_HEADERS = \ | 35 | noinst_HEADERS = \ |
36 | controller/actions/clear_selection.h \ | 36 | controller/actions/clear_selection.h \ |
@@ -47,8 +47,8 @@ noinst_HEADERS = \ | |||
47 | controller/callbacks/mouse_wheel.h \ | 47 | controller/callbacks/mouse_wheel.h \ |
48 | controller/callbacks/reshape.h \ | 48 | controller/callbacks/reshape.h \ |
49 | db/dbconnect.h \ | 49 | db/dbconnect.h \ |
50 | model/exp004base.h \ | 50 | model/base.h \ |
51 | model/exp004state.h \ | 51 | model/state.h \ |
52 | model/geometry/density_legend_geometry.h \ | 52 | model/geometry/density_legend_geometry.h \ |
53 | model/geometry/map_geometry.h \ | 53 | model/geometry/map_geometry.h \ |
54 | model/geometry/protein_geometry.h \ | 54 | model/geometry/protein_geometry.h \ |
@@ -62,10 +62,10 @@ noinst_HEADERS = \ | |||
62 | util/check_error.h \ | 62 | util/check_error.h \ |
63 | util/pick_convert.h \ | 63 | util/pick_convert.h \ |
64 | util/sqlinfoprint.h \ | 64 | util/sqlinfoprint.h \ |
65 | view/exp004geometry.h \ | 65 | view/geometry.h \ |
66 | view/exp004init.h \ | 66 | view/init.h \ |
67 | view/exp004state0.h \ | 67 | view/state0.h \ |
68 | view/exp004view.h | 68 | view/view.h |
69 | 69 | ||
70 | # The Linux non-free driver does not appear to include the | 70 | # The Linux non-free driver does not appear to include the |
71 | # implementations of the AMD_performance_monitor functions. | 71 | # implementations of the AMD_performance_monitor functions. |
@@ -86,4 +86,4 @@ CLEANFILES = \ | |||
86 | controller/actions/selection_from_db.c \ | 86 | controller/actions/selection_from_db.c \ |
87 | controller/actions/sel_save.c \ | 87 | controller/actions/sel_save.c \ |
88 | db/dbconnect.c \ | 88 | db/dbconnect.c \ |
89 | model/exp004base.c | 89 | model/base.c |