36 files changed, 332 insertions, 176 deletions
diff --git a/src/Makefile.am b/src/Makefile.am index 3bb95ee..1ccb4f8 100644 --- a/src/Makefile.am +++ b/src/Makefile.am | |||
@@ -1,17 +1,18 @@ | |||
1 | bin_PROGRAMS = exp004viz | 1 | bin_PROGRAMS = exp004viz |
2 | 2 | ||
3 | exp004viz_SOURCES = \ | 3 | exp004viz_SOURCES = \ |
4 | controller/clear_selection.c \ | 4 | controller/actions/clear_selection.c \ |
5 | controller/exp004display.c \ | 5 | controller/actions/pan.c \ |
6 | controller/exp004mouse.c \ | 6 | controller/actions/process_hits.c \ |
7 | controller/exp004processhits.c \ | 7 | controller/actions/sel_save.c \ |
8 | controller/exp004reshape.c \ | 8 | controller/actions/selection_from_db.c \ |
9 | controller/keyboard.c \ | 9 | controller/actions/set_ortho.c \ |
10 | controller/mousewheel.c \ | 10 | controller/actions/zoom.c \ |
11 | controller/performzoom.c \ | 11 | controller/callbacks/display.c \ |
12 | controller/selection_from_db.c \ | 12 | controller/callbacks/keyboard.c \ |
13 | controller/selsave.c \ | 13 | controller/callbacks/mouse.c \ |
14 | controller/set_ortho.c \ | 14 | controller/callbacks/mouse_wheel.c \ |
15 | controller/callbacks/reshape.c \ | ||
15 | db/dbconnect.c \ | 16 | db/dbconnect.c \ |
16 | exp004viz.c \ | 17 | exp004viz.c \ |
17 | model/exp004base.c \ | 18 | model/exp004base.c \ |
@@ -32,24 +33,26 @@ exp004viz_SOURCES = \ | |||
32 | exp004viz_LDADD = ${GLUT_LIBS} | 33 | exp004viz_LDADD = ${GLUT_LIBS} |
33 | 34 | ||
34 | noinst_HEADERS = \ | 35 | noinst_HEADERS = \ |
35 | controller/clear_selection.h \ | 36 | controller/actions/clear_selection.h \ |
36 | controller/exp004display.h \ | 37 | controller/actions/pan.h \ |
37 | controller/exp004mouse.h \ | 38 | controller/actions/process_hits.h \ |
38 | controller/exp004processhits.h \ | 39 | controller/actions/sel_save.h \ |
39 | controller/exp004reshape.h \ | 40 | controller/actions/selection_from_db.h \ |
40 | controller/keyboard.h \ | 41 | controller/actions/set_ortho.h \ |
41 | controller/mousewheel.h \ | 42 | controller/actions/vis_sel_set.h \ |
42 | controller/performzoom.h \ | 43 | controller/actions/zoom.h \ |
43 | controller/selection_from_db.h \ | 44 | controller/callbacks/display.h \ |
44 | controller/selsave.h \ | 45 | controller/callbacks/keyboard.h \ |
45 | controller/set_ortho.h \ | 46 | controller/callbacks/mouse.h \ |
47 | controller/callbacks/mouse_wheel.h \ | ||
48 | controller/callbacks/reshape.h \ | ||
46 | db/dbconnect.h \ | 49 | db/dbconnect.h \ |
47 | model/exp004base.h \ | 50 | model/exp004base.h \ |
48 | model/exp004state.h \ | 51 | model/exp004state.h \ |
49 | model/geometry/density_legend_geometry.h \ | 52 | model/geometry/density_legend_geometry.h \ |
53 | model/geometry/map_geometry.h \ | ||
50 | model/geometry/protein_geometry.h \ | 54 | model/geometry/protein_geometry.h \ |
51 | model/geometry/protein_selected_geometry.h \ | 55 | model/geometry/protein_selected_geometry.h \ |
52 | model/geometry/map_geometry.h \ | ||
53 | model/selection_info.h \ | 56 | model/selection_info.h \ |
54 | model/selection_info_init.h \ | 57 | model/selection_info_init.h \ |
55 | model/selection_purposes.h \ | 58 | model/selection_purposes.h \ |
@@ -79,8 +82,8 @@ AM_CFLAGS = -Wall -ggdb -std=gnu99 -pipe -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_S | |||
79 | db2 PRECOMPILE $<; | 82 | db2 PRECOMPILE $<; |
80 | 83 | ||
81 | CLEANFILES = \ | 84 | CLEANFILES = \ |
82 | controller/clear_selection.c \ | 85 | controller/actions/clear_selection.c \ |
83 | controller/selection_from_db.c \ | 86 | controller/actions/selection_from_db.c \ |
84 | controller/selsave.c \ | 87 | controller/actions/sel_save.c \ |
85 | db/dbconnect.c \ | 88 | db/dbconnect.c \ |
86 | model/exp004base.c | 89 | model/exp004base.c |