27 files changed, 179 insertions, 549 deletions
diff --git a/src/Makefile.am b/src/Makefile.am index e2a3b72..c7f33a0 100644 --- a/src/Makefile.am +++ b/src/Makefile.am | |||
@@ -11,17 +11,19 @@ flumap_SOURCES = \ | |||
11 | controller/callbacks/display.c \ | 11 | controller/callbacks/display.c \ |
12 | controller/callbacks/keyboard.c \ | 12 | controller/callbacks/keyboard.c \ |
13 | controller/callbacks/mouse.c \ | 13 | controller/callbacks/mouse.c \ |
14 | controller/callbacks/mouse_motion.c \ | ||
14 | controller/callbacks/mouse_wheel.c \ | 15 | controller/callbacks/mouse_wheel.c \ |
15 | controller/callbacks/reshape.c \ | 16 | controller/callbacks/reshape.c \ |
16 | db/dbconnect.c \ | 17 | db/dbconnect.c \ |
17 | flumap.c \ | 18 | flumap.c \ |
18 | model/base.c \ | 19 | model/data/base.c \ |
19 | model/geometry/density_legend_geometry.c \ | 20 | model/geometry/density_legend_geometry.c \ |
20 | model/geometry/map_geometry.c \ | 21 | model/geometry/map_geometry.c \ |
21 | model/geometry/protein_geometry.c \ | 22 | model/geometry/protein_geometry.c \ |
22 | model/geometry/protein_selected_geometry.c \ | 23 | model/geometry/protein_selected_geometry.c \ |
23 | model/selection_info_init.c \ | 24 | model/state/pan_info_init.c \ |
24 | model/zoom_info_init.c \ | 25 | model/state/selection_info_init.c \ |
26 | model/state/zoom_info_init.c \ | ||
25 | util/ati_meminfo.c \ | 27 | util/ati_meminfo.c \ |
26 | util/check_error.c \ | 28 | util/check_error.c \ |
27 | util/pick_convert.c \ | 29 | util/pick_convert.c \ |
@@ -44,20 +46,23 @@ noinst_HEADERS = \ | |||
44 | controller/callbacks/display.h \ | 46 | controller/callbacks/display.h \ |
45 | controller/callbacks/keyboard.h \ | 47 | controller/callbacks/keyboard.h \ |
46 | controller/callbacks/mouse.h \ | 48 | controller/callbacks/mouse.h \ |
49 | controller/callbacks/mouse_motion.h \ | ||
47 | controller/callbacks/mouse_wheel.h \ | 50 | controller/callbacks/mouse_wheel.h \ |
48 | controller/callbacks/reshape.h \ | 51 | controller/callbacks/reshape.h \ |
49 | db/dbconnect.h \ | 52 | db/dbconnect.h \ |
50 | model/base.h \ | 53 | model/data/base.h \ |
51 | model/state.h \ | 54 | model/data/coordinates.h \ |
52 | model/geometry/density_legend_geometry.h \ | 55 | model/geometry/density_legend_geometry.h \ |
53 | model/geometry/map_geometry.h \ | 56 | model/geometry/map_geometry.h \ |
54 | model/geometry/protein_geometry.h \ | 57 | model/geometry/protein_geometry.h \ |
55 | model/geometry/protein_selected_geometry.h \ | 58 | model/geometry/protein_selected_geometry.h \ |
56 | model/selection_info.h \ | 59 | model/state/pan_info.h \ |
57 | model/selection_info_init.h \ | 60 | model/state/selection_info.h \ |
58 | model/selection_purposes.h \ | 61 | model/state/selection_info_init.h \ |
59 | model/zoom_info.h \ | 62 | model/state/selection_purposes.h \ |
60 | model/zoom_info_init.h \ | 63 | model/state/state.h \ |
64 | model/state/zoom_info.h \ | ||
65 | model/state/zoom_info_init.h \ | ||
61 | util/ati_meminfo.h \ | 66 | util/ati_meminfo.h \ |
62 | util/check_error.h \ | 67 | util/check_error.h \ |
63 | util/pick_convert.h \ | 68 | util/pick_convert.h \ |
@@ -86,4 +91,4 @@ CLEANFILES = \ | |||
86 | controller/actions/selection_from_db.c \ | 91 | controller/actions/selection_from_db.c \ |
87 | controller/actions/sel_save.c \ | 92 | controller/actions/sel_save.c \ |
88 | db/dbconnect.c \ | 93 | db/dbconnect.c \ |
89 | model/base.c | 94 | model/data/base.c |