summaryrefslogtreecommitdiffstats
Unidiff
-rw-r--r--AUTHORS1
-rw-r--r--Makefile.am2
-rw-r--r--README24
-rw-r--r--ax/acx_pthread.m4242
-rw-r--r--ax/ax_check_gl.m495
-rw-r--r--ax/ax_check_glu.m471
-rw-r--r--ax/ax_check_glut.m478
-rw-r--r--ax/ax_lang_compiler_ms.m423
-rw-r--r--configure.ac24
-rw-r--r--src/Makefile.am28
-rw-r--r--src/controller/exp004display.c16
-rw-r--r--src/controller/exp004display.h6
-rw-r--r--src/controller/exp004mouse.c90
-rw-r--r--src/controller/exp004mouse.h6
-rw-r--r--src/controller/exp004processhits.c54
-rw-r--r--src/controller/exp004processhits.h8
-rw-r--r--src/controller/exp004reshape.c55
-rw-r--r--src/controller/exp004reshape.h6
-rw-r--r--src/exp004viz.c15
-rw-r--r--src/model/exp004base.c107
-rw-r--r--src/model/exp004base.h9
-rw-r--r--src/model/exp004state.h101
-rw-r--r--src/util/check_error.c17
-rw-r--r--src/util/check_error.h9
-rw-r--r--src/view/exp004geometry.c32
-rw-r--r--src/view/exp004geometry.h8
-rw-r--r--src/view/exp004state0.h8
-rw-r--r--src/view/exp004view.c44
-rw-r--r--src/view/exp004view.h6
29 files changed, 1185 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..bd0d702
--- a/dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,28 @@
1bin_PROGRAMS = exp004viz
2
3exp004viz_SOURCES = \
4 controller/exp004display.c \
5 controller/exp004mouse.c \
6 controller/exp004processhits.c \
7 controller/exp004reshape.c \
8 exp004viz.c \
9 model/exp004base.c \
10 util/check_error.c \
11 view/exp004geometry.c \
12 view/exp004view.c
13
14exp004viz_LDADD = ${GLUT_LIBS}
15
16noinst_HEADERS = \
17 controller/exp004display.h \
18 controller/exp004mouse.h \
19 controller/exp004processhits.h \
20 controller/exp004reshape.h \
21 model/exp004base.h \
22 model/exp004state.h \
23 util/check_error.h \
24 view/exp004geometry.h \
25 view/exp004state0.h \
26 view/exp004view.h
27
28AM_CFLAGS = -Wall -std=gnu99 -pipe -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -I/usr/include/ncbi

Valid XHTML 1.0 Strict

Copyright © 2009 Don Pellegrino All Rights Reserved.