summaryrefslogtreecommitdiffstats
Side-by-side diff
-rw-r--r--AUTHORS1
-rw-r--r--Makefile.am2
-rw-r--r--README24
-rw-r--r--ax/acx_pthread.m4242
-rw-r--r--ax/ax_check_gl.m495
-rw-r--r--ax/ax_check_glu.m471
-rw-r--r--ax/ax_check_glut.m478
-rw-r--r--ax/ax_lang_compiler_ms.m423
-rw-r--r--configure.ac24
-rw-r--r--src/Makefile.am28
-rw-r--r--src/controller/exp004display.c16
-rw-r--r--src/controller/exp004display.h6
-rw-r--r--src/controller/exp004mouse.c90
-rw-r--r--src/controller/exp004mouse.h6
-rw-r--r--src/controller/exp004processhits.c54
-rw-r--r--src/controller/exp004processhits.h8
-rw-r--r--src/controller/exp004reshape.c55
-rw-r--r--src/controller/exp004reshape.h6
-rw-r--r--src/exp004viz.c15
-rw-r--r--src/model/exp004base.c107
-rw-r--r--src/model/exp004base.h9
-rw-r--r--src/model/exp004state.h101
-rw-r--r--src/util/check_error.c17
-rw-r--r--src/util/check_error.h9
-rw-r--r--src/view/exp004geometry.c32
-rw-r--r--src/view/exp004geometry.h8
-rw-r--r--src/view/exp004state0.h8
-rw-r--r--src/view/exp004view.c44
-rw-r--r--src/view/exp004view.h6
29 files changed, 1185 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..bd0d702
--- a/dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,28 @@
+bin_PROGRAMS = exp004viz
+
+exp004viz_SOURCES = \
+ controller/exp004display.c \
+ controller/exp004mouse.c \
+ controller/exp004processhits.c \
+ controller/exp004reshape.c \
+ exp004viz.c \
+ model/exp004base.c \
+ util/check_error.c \
+ view/exp004geometry.c \
+ view/exp004view.c
+
+exp004viz_LDADD = ${GLUT_LIBS}
+
+noinst_HEADERS = \
+ controller/exp004display.h \
+ controller/exp004mouse.h \
+ controller/exp004processhits.h \
+ controller/exp004reshape.h \
+ model/exp004base.h \
+ model/exp004state.h \
+ util/check_error.h \
+ view/exp004geometry.h \
+ view/exp004state0.h \
+ view/exp004view.h
+
+AM_CFLAGS = -Wall -std=gnu99 -pipe -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -I/usr/include/ncbi

Valid XHTML 1.0 Strict

Copyright © 2009 Don Pellegrino All Rights Reserved.