-rw-r--r-- | README | 21 | ||||
-rw-r--r-- | configure.ac | 28 |
2 files changed, 37 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac index 4e0c4ba..fa1de7a 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -7,14 +7,38 @@ AC_CONFIG_FILES([ | |||
7 | src/Makefile | 7 | src/Makefile |
8 | ]) | 8 | ]) |
9 | 9 | ||
10 | ################## | ||
11 | # MODULE: OpenGL # | ||
12 | ################## | ||
13 | |||
14 | # Note that this project will not build on systems where the OpenGL | ||
15 | # support libraries do not include support for buffer objects. | ||
16 | |||
10 | # Check for OpenGL libraries GLUT, GLU and GL. OpenGL is used for the | 17 | # Check for OpenGL libraries GLUT, GLU and GL. OpenGL is used for the |
11 | # visualization rendering and interaction. | 18 | # visualization rendering and interaction. |
12 | AX_CHECK_GLUT | 19 | AX_CHECK_GLUT |
13 | 20 | ||
14 | # Check for DB2. | 21 | ############### |
15 | AC_SEARCH_LIBS([sqlastrt],[db2]) | 22 | # MODULE: DB2 # |
23 | ############### | ||
24 | |||
25 | # Check for DB2 client library. | ||
26 | AC_SEARCH_LIBS([sqlastrt],[db2],[], | ||
27 | [AC_MSG_ERROR(The DB2 client libraries are needed to build the system. After installation of the client it may be necessary to add -L/home/db2inst1/sqllib/lib to LDFLAGS.)]) | ||
28 | |||
29 | # Check for DB2 client headers. | ||
30 | AC_CHECK_HEADERS([sqladef.h],[], | ||
31 | [AC_MSG_ERROR(The DB2 client headers are needed to build the system. After installation of the client it may be necessary to add -I/home/db2inst1/sqllib/include to CPPFLAGS.)]) | ||
32 | |||
33 | ########################## | ||
34 | # MODULE: BROWSER PLUGIN # | ||
35 | ########################## | ||
16 | 36 | ||
17 | # Libtool is used to build the library for the browser plugin. | 37 | # Libtool is used to build the library for the browser plugin. |
18 | AC_PROG_LIBTOOL | 38 | AC_PROG_LIBTOOL |
19 | 39 | ||
40 | # Check for the Gecko Plugin API | ||
41 | AC_CHECK_HEADERS([npapi.h],[], | ||
42 | [AC_MSG_ERROR(The Gecko Plugin API (NPAPI) is needed to build the system. Information on this API can be found on-line at https://developer.mozilla.org/en/Plugins. Debian users can add the package xulrunner-dev and add -I/usr/include/xulrunner-1.9/unstable to CPPFLAGS.)]) | ||
43 | |||
20 | AC_OUTPUT | 44 | AC_OUTPUT |