summaryrefslogtreecommitdiffstats
Side-by-side diff
-rw-r--r--AUTHORS1
-rw-r--r--Makefile.am2
-rw-r--r--README24
-rw-r--r--ax/acx_pthread.m4242
-rw-r--r--ax/ax_check_gl.m495
-rw-r--r--ax/ax_check_glu.m471
-rw-r--r--ax/ax_check_glut.m478
-rw-r--r--ax/ax_lang_compiler_ms.m423
-rw-r--r--configure.ac24
-rw-r--r--src/Makefile.am28
-rw-r--r--src/controller/exp004display.c16
-rw-r--r--src/controller/exp004display.h6
-rw-r--r--src/controller/exp004mouse.c90
-rw-r--r--src/controller/exp004mouse.h6
-rw-r--r--src/controller/exp004processhits.c54
-rw-r--r--src/controller/exp004processhits.h8
-rw-r--r--src/controller/exp004reshape.c55
-rw-r--r--src/controller/exp004reshape.h6
-rw-r--r--src/exp004viz.c15
-rw-r--r--src/model/exp004base.c107
-rw-r--r--src/model/exp004base.h9
-rw-r--r--src/model/exp004state.h101
-rw-r--r--src/util/check_error.c17
-rw-r--r--src/util/check_error.h9
-rw-r--r--src/view/exp004geometry.c32
-rw-r--r--src/view/exp004geometry.h8
-rw-r--r--src/view/exp004state0.h8
-rw-r--r--src/view/exp004view.c44
-rw-r--r--src/view/exp004view.h6
29 files changed, 1185 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..a7924d3
--- a/dev/null
+++ b/configure.ac
@@ -0,0 +1,24 @@
+AC_INIT([exp005], [0.1], [don@drexel.edu])
+AM_INIT_AUTOMAKE([-Wall, -Werror, -Wno-portability])
+AC_PROG_CC
+AM_CONFIG_HEADER([config.h])
+AC_CONFIG_FILES([
+ Makefile
+ src/Makefile
+])
+
+# Check for OpenGL libraries GLUT, GLU and GL. OpenGL is used for the
+# visualization rendering and interaction.
+AX_CHECK_GLUT
+
+# Check for the NCBI Toolkit libraries.
+AC_SEARCH_LIBS([log10],[m])
+AC_SEARCH_LIBS([NlmThreadsAvailable],[ncbi])
+AC_SEARCH_LIBS([SeqAlignNew],[ncbiobj])
+AC_SEARCH_LIBS([Blast_RedoOneMatch],[blastcompadj])
+AC_SEARCH_LIBS([BioseqBlastEngine],[ncbitool])
+
+# Check for the new curses library for terminal output.
+AC_SEARCH_LIBS([clrtoeol],[ncurses])
+
+AC_OUTPUT

Valid XHTML 1.0 Strict

Copyright © 2009 Don Pellegrino All Rights Reserved.